tijdstippen uitsluiten in datum en tijdkolom

Stel hier je vraag over een Excel probleem
Ralph123
Berichten: 4
Lid geworden op: 27 jul 2020 13:22

tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor Ralph123 » 30 jul 2020 11:06

Hallo,

Ik heb een simpele vraag maar krijg het niet voor elkaar.
Mijn bestand komt uit een database waarin storingsmeldingen zijn opgeslagen.
Voor mijn vraag beschrijf ik maar drie kolommen: storingsmelding, een meldingstijd en een datum gemeld.
Hiermee kun je mooie grafieken maken zoals het aantal storingen per week of per maand of op welke dag.
Graag wil ik het aantal storingen zien die buiten de regulier tijd vallen (binnen een bepaalde periode) en dat is dan de zaterdag en zondag maar ook maandag t/m vrijdag tussen 16:30 en 8:00.
De moeilijkheid zit hem bij mij dat ik twee kolommen heb (datum en tijd) waarmee een functie gemaakt moet worden.
De meldingen binnen reguliertijd moeten gescheiden kunnen worden van de meldingen buiten reguliere tijd. dit mag in een nieuwe kolom en met 1 en 0 of tekst.

Alvast dank
haije
Berichten: 82
Lid geworden op: 29 okt 2019 09:45

Re: tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor haije » 30 jul 2020 12:26

Hallo Ralph,

kun je een bestandje plaatsen met daarin een aantal van ie databaseregels, ZONDER "gevoelige" informatie?
Popipipo
Berichten: 35
Lid geworden op: 20 jun 2019 12:08

Re: tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor Popipipo » 30 jul 2020 14:30

Zet de datum en tijd van binnen de regulier werktijd in andere kolommen dan buiten de reguliere werktijd.
Bijlagen
reguliere tijd.xlsm
(11.58 KiB) 7 keer gedownload
Ralph123
Berichten: 4
Lid geworden op: 27 jul 2020 13:22

Re: tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor Ralph123 » 03 aug 2020 09:17

haije schreef:
30 jul 2020 12:26
Hallo Ralph,

kun je een bestandje plaatsen met daarin een aantal van ie databaseregels, ZONDER "gevoelige" informatie?
Hierbij het bestand met twee tabbladen.
Eerste tabblad is de data en het tweede tabblad is een kolom toegevoegd met het gewenste resultaat.
Tevens staan hier nog twee hulpkolommen bij die ik gebruik voor het gewenste resultaat.
Bijlagen
Test_binnen_buiten_werktijd.xlsx
(27.03 KiB) 5 keer gedownload
Ralph123
Berichten: 4
Lid geworden op: 27 jul 2020 13:22

Re: tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor Ralph123 » 03 aug 2020 09:19

Popipipo schreef:
30 jul 2020 14:30
Zet de datum en tijd van binnen de regulier werktijd in andere kolommen dan buiten de reguliere werktijd.
Hallo Popipipo,

Bedankt voor je inspanning maar het voldoet niet helemaal aan mijn verwachting.
Graag zou ik in een kolom het resultaat willen zien. zodat ik hierop kan filteren en grafieken kan maken.

Gr,
Ralph
haije
Berichten: 82
Lid geworden op: 29 okt 2019 09:45

Re: tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor haije » 03 aug 2020 09:49

voor d2 in tabblad Data:

=ALS(WEEKDAG(B2;2)>5;"weekend";ALS(EN(C2>=8/24;C2<=16,5/24);"binnen";"Buiten"))
Ralph123
Berichten: 4
Lid geworden op: 27 jul 2020 13:22

Re: tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor Ralph123 » 03 aug 2020 14:39

haije schreef:
03 aug 2020 09:49
voor d2 in tabblad Data:

=ALS(WEEKDAG(B2;2)>5;"weekend";ALS(EN(C2>=8/24;C2<=16,5/24);"binnen";"Buiten"))
Hallo haije,

Bedankt voor de oplossing met het juiste resultaat. :D
haije
Berichten: 82
Lid geworden op: 29 okt 2019 09:45

Re: tijdstippen uitsluiten in datum en tijdkolom

Berichtdoor haije » 03 aug 2020 16:57

Graag gedaan!

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 7 gasten