Te veel argumenten probleem

Stel hier je vraag over een Excel probleem
Plaats reactie
Sara1980
Berichten: 6
Lid geworden op: 29 okt 2020 12:51

Te veel argumenten probleem

Bericht door Sara1980 » 02 nov 2020 08:20

Goedemorgen!

Ik heb het volgende probleem. Bijgevoegd een simpele versie van het werkelijke bestand.

Op basis van het aantal personen moet de hoeveelheid van een bepaald apparaat worden doorgevoerd. Dus bijvoorbeeld bij 900 personen moeten er 3 afzuigkappen komen. Het probleem bij deze formule is dat ik de volgende melding krijg; 'U hebt te veel argumenten opgegeven voor deze functie.' Ik ben opzoek of naar een manier om toch zoveel argumenten in te voeren of wel een ander formule te gebruiken voor wat ik wil bereiken.

Wie kan mij helpen!
Bijlagen
Voorbeeld Excel.xlsx
(9.3 KiB) 15 keer gedownload

haije
Berichten: 131
Lid geworden op: 29 okt 2019 09:45

Re: Te veel argumenten probleem

Bericht door haije » 02 nov 2020 08:49

probeer deze eens:

Code: Selecteer alles

=ALS($C$2<251;ALS($C$2<601;2);3)

jkpieterse
Site Admin
Berichten: 806
Lid geworden op: 30 jan 2017 14:32

Re: Te veel argumenten probleem

Bericht door jkpieterse » 02 nov 2020 09:06

Zie bijlage. Ik heb de X.ZOEKEN functie gebruikt en een iets andere manier om de grenzen aan te geven.

Code: Selecteer alles

=X.ZOEKEN(C2;C4:I4;C6:I6;;1;1)
Bijlagen
Voorbeeld Excel.xlsx
(10.4 KiB) 15 keer gedownload
Groetjes,
Jan Karel Pieterse
jkp-ads.com

Sara1980
Berichten: 6
Lid geworden op: 29 okt 2020 12:51

Re: Te veel argumenten probleem

Bericht door Sara1980 » 02 nov 2020 09:06

Het werkt inderdaad! Helaas wel alleen als het aantal personen >251 is.
Daarnaast moet ik zeggen dat het een hele lange lijst van apparaten is (met verschillende hoeveelheden per categorie) en ik op zoek ben naar een formule die gelijk blijft voor elk apparaat.

Ik merk dat als ik de formule die ik eerst had gebruik, ik net 1 categorie te veel heb. Bij 6 categorieën kan ik de formule namelijk wel gebruiken. Enige idee hoe het aantal argumenten kan vergroten?

Sara1980
Berichten: 6
Lid geworden op: 29 okt 2020 12:51

Re: Te veel argumenten probleem

Bericht door Sara1980 » 02 nov 2020 09:11

jkpieterse schreef:
02 nov 2020 09:06
Zie bijlage. Ik heb de X.ZOEKEN functie gebruikt en een iets andere manier om de grenzen aan te geven.

Code: Selecteer alles

=X.ZOEKEN(C2;C4:I4;C6:I6;;1;1)
Top Dankjewel!

Plaats reactie