Pagina 1 van 1

als functie

Geplaatst: 02 sep 2020 11:15
door Erwin1970
Als Functie formule

Ik zou de formule weten om reiskosten te berekenen aan de hand van gewerkte uren.

Als ik 0 uur invul zou de uitkomst ook 0 zijn
Als ik 8 uur of hoger invul zou de uikomst 0.19 moeten zijn
Als ik 16 uur of hoger invul zou de uikomst 0.38 moeten zijn
en zo door tot 56 uur met de uitkomst 1.33

Wie kan mij helpen
groetjes

Erwin

Re: als functie

Geplaatst: 02 sep 2020 12:57
door tknijnenburg
Zie bijlage. De als.voorwaarden is vanaf O365 beschikbaar. Voor de als formule heb ik een deel gemaakt.

Re: als functie

Geplaatst: 02 sep 2020 13:27
door Erwin1970
Beste Ton,

Bedankt voor je reactie, maar als ik de gewerkte uren verander van 15 naar 7 zie ik dit
gewerkte uren reiskosten reiskosten
7 #NAAM? ONWAAR

Grtz

Re: als functie

Geplaatst: 02 sep 2020 15:26
door tknijnenburg
Beste Erwin,
Dat klopt.
De als.voorwaarden formule (in B2) is beschikbaar in Excel 365, ik weet niet welk versie jij hebt.
De als formule (in C2) heb ik deels gemaakt, hieronder een stuk extra. Je mag deze zelf verder afmaken.
=ALS(A2=0;0;ALS(EN(A2>=8;A2<16);0,19;ALS(EN(A2>=16;A2<24);0,38)))

Re: als functie

Geplaatst: 02 sep 2020 17:03
door Ad Becude
Of je doet het zo:

Re: als functie

Geplaatst: 02 sep 2020 17:05
door Popipipo
Om dat er een grote mate van regelmaat in zit kun je ook deze formule gebruiken.

=MIN(1,33;ROUNDDOWN(A2/8;0)*0,19)

Re: als functie

Geplaatst: 03 sep 2020 08:53
door Erwin1970
Ik gebruik office 2016 professional nederlands.

Ik heb ook een klein foutje in de uitleg gegeven
Als ik 0 uur invul zou de uitkomst ook 0 zijn
Als ik 1 tot 8 uur of hoger invul zou de uikomst 0.19 moeten zijn
Als ik 9 tot 16 uur of hoger invul zou de uikomst 0.38 moeten zijn
en zo door tot 48 tot 56 uur met de uitkomst 1.33

Ik merk dat de formule van de heer tknijnenburg niet werkt in deze excel versie

De oplossing van de heer Ad Becude werkt wel maar ik heb in andere sheets de als formule nodig, en wil deze verder begrijpen

De formule van de heer Popipipo werkt deels als ik rounddown verander in afronden maar omdat ik een foutje in de uitleg heb gegeven klopt het op dit moment nog niet

Bedankt voor jullie reacties

Re: als functie

Geplaatst: 03 sep 2020 09:11
door Erwin1970
Beste heer tknijnenburg

Ik heb de formule afgemaakt

=ALS(B4=0;0;ALS(EN(B4>=1;B4<9);0,19;ALS(EN(B4>=9;B4<17);0,38;ALS(EN(B4>=17;B4<25);0,57;ALS(EN(B4>=25;B4<33);0,76;ALS(EN(B4>=33;B4<41);0,95;ALS(EN(B4>=41;B4<49);1,14;ALS(EN(B4>=49;B4<57);1,33))))))))

En hij werkt perfect

Dank u voor de moeite

Re: als functie

Geplaatst: 03 sep 2020 10:29
door Popipipo
=MIN(1,33;AFRONDEN.NAAR.BENEDEN(A2/8;0)*0,19)

Dit is de vertaling naar het nederlands.

Re: als functie

Geplaatst: 03 sep 2020 11:55
door Erwin1970
Beste Popipipo,

Bedankt voor de juiste formule.

Groet

Erwin