Somproduct - somproduct als

Stel hier je vraag over een Excel probleem
Plaats reactie
Pietjeisoke
Berichten: 5
Lid geworden op: 07 mei 2020 20:12

Somproduct - somproduct als

Bericht door Pietjeisoke » 03 mei 2021 12:13

Hoi allen,

Ik heb een excelbestand voor het afhandelen van de bestellingen van mijn webshop. Om te zien hoeveel ik van wat verkoop gebruik ik een somproductforumule. Die ziet er als volgt uit:=SOMPRODUCT(($C$2:$C$105=Q4)*($D$2:$D$105))+SOMPRODUCT(($E$2:$E$105=Q4)*($F$2:$F$105))

Ik heb twee rijen voor als de consument 2 verschillende producten besteld. Nu wil ik graag zien hoeveel bestellingen ik nog niet afgehandeld heb, hiervoor heb ik een kolom met ''nee'' en ''ja'' voor afgehandeld en heb ik de volgende formule geschreven:

=SOMPRODUCT(($C$2:$C$105=Q4)*($D$2:$D$105))+SOMPRODUCT(($E$2:$E$105=Q4)*($F$2:$F$105)) - ALS(N2:N105=''ja'';(=SOMPRODUCT(($C$2:$C$105=Q4)*($D$2:$D$105))+SOMPRODUCT(($E$2:$E$105=Q4)*($F$2:$F$105));0)

Hier klopt echter niks van. Wie kan me helpen om een formule te schrijven voor het aantal niet afgehandelde producten?

Groetjes,
Pieter

Gebruikersavatar
tknijnenburg
Berichten: 344
Lid geworden op: 18 feb 2019 17:04

Re: Somproduct - somproduct als

Bericht door tknijnenburg » 03 mei 2021 12:16

Heb je een voorbeeld bestandje zonder gevoelige gegevens, dat werkt makkelijker.
Grtz, Ton
kn-ict.com

jkpieterse
Site Admin
Berichten: 947
Lid geworden op: 30 jan 2017 14:32

Re: Somproduct - somproduct als

Bericht door jkpieterse » 03 mei 2021 12:25

Klinkt alsof dit eenvoudig met een draaitabelletje moet kunnen, maar inderdaad, kan je een representatief (anoniem) voorbeeldje maken?
Groetjes,
Jan Karel Pieterse
jkp-ads.com

Gebruikersavatar
Roel1973
Berichten: 317
Lid geworden op: 09 jan 2021 15:58

Re: Somproduct - somproduct als

Bericht door Roel1973 » 03 mei 2021 17:16

Hallo Pieter,

Als je denkt dat de formule wel klopt - dat kunnen we niet checken zonder proefbestand - dan zie ik in elk geval een fout in de opbouw. Het = teken bij de eerste SOMPRODUCT functie die is genest in de ALS functie, moet weg. Zie vet en onderstreept teken aan het begin van de 2e regel:

=SOMPRODUCT(($C$2:$C$105=Q4)*($D$2:$D$105))+SOMPRODUCT(($E$2:$E$105=Q4)*($F$2:$F$105)) - ALS(N2:N105=''ja'';(=SOMPRODUCT(($C$2:$C$105=Q4)*($D$2:$D$105))+SOMPRODUCT(($E$2:$E$105=Q4)*($F$2:$F$105));0)

Maar goed, mogelijk gaat er meer fout en dat kan ik zonder voorbeeld niet zien.
Met vriendelijke groet,

Roel Janssen
www.structuurmakers.nl

Pietjeisoke
Berichten: 5
Lid geworden op: 07 mei 2020 20:12

Re: Somproduct - somproduct als

Bericht door Pietjeisoke » 04 mei 2021 17:39

Hartelijk dank voor de reacties

Hierbij een voorbeeldbestand. Omdat ik de formule niet gedaan krijg heb ik ALS(I2=''Ja'';1;0) staan, met 1 bedoel ik uiteraard het aantal afgehandelde producten.

Bedankt!
Bijlagen
Map1.xlsx
(10.15 KiB) 4 keer gedownload

Gebruikersavatar
Roel1973
Berichten: 317
Lid geworden op: 09 jan 2021 15:58

Re: Somproduct - somproduct als

Bericht door Roel1973 » 04 mei 2021 18:39

Hallo Pieter,

Bijgaand de oplossing maar met SOM.ALS en SOMMEN.ALS functies. Dat houdt het simpel en overzichtelijk in dit geval.

Zie ook mijn blog hierover, waarin ik uitleg wanneer je SOMPRODUCT gebruikt en wanneer je SOM(MEN).ALS kunt gebruiken: https://www.structuurmakers.nl/excel/so ... ommen-als/
Bijlagen
Map1_RJ.xlsx
(17.59 KiB) 12 keer gedownload
Met vriendelijke groet,

Roel Janssen
www.structuurmakers.nl

Pietjeisoke
Berichten: 5
Lid geworden op: 07 mei 2020 20:12

Re: Somproduct - somproduct als

Bericht door Pietjeisoke » 04 mei 2021 19:13

Wauw! Heel erg bedankt. Precies wat ik zocht. Sommen.Als is inderdaad veel overzichtelijker!

Plaats reactie